Некорректная работа компонента "Сварной двутавр"

Ответить
Владимир Шнейдер
Сообщения: 283
Регистрация: 03 фев 2012, 17:29
Откуда: Днепропетровск

Некорректная работа компонента "Сварной двутавр"

Сообщение Владимир Шнейдер » 14 дек 2013, 19:18

Никто не сталкивался - компонент "Сварной двутвар" (и аналогичные ему "Сварной короб" и т.п.) из среды КМД_РУС - не позволяют фильтровать детали по марке стали (материалу)? Детали, созданные компонентом, скрываются при любом значении фильтра "Детали - материал". Расчленение компонента не помогает.
Предпологаю, что причина может быть в создании компонента в старой версии Tekla (работаю в 17-ой), и при этом используется такой странный пользовательский атрибут, как "proMaterial", при этом в пользовательских атрибутах детали его нет, а в дереве компонента есть:
snap_001.png

Аватара пользователя
Danila_ZLT
Сообщения: 580
Регистрация: 02 окт 2012, 12:14
Откуда: Златоуст
Контактная информация:

Re: Некорректная работа компонента "Сварной двутавр"

Сообщение Danila_ZLT » 15 дек 2013, 17:04

За материал и профиль отвечает вкладочка "Profile properties".
IMHO Как-то странно вы себе структуру Теклы себе представляете. Ищете профиль и материал в "Определенных пользователем атрибутах".
Автоматизируем хаос... Недорого...
http://www.zzmk.ru

Аватара пользователя
vladimir_a
Сообщения: 591
Регистрация: 07 дек 2011, 21:22

Re: Некорректная работа компонента "Сварной двутавр"

Сообщение vladimir_a » 15 дек 2013, 18:00

Владимир Шнейдер писал(а):Никто не сталкивался - компонент "Сварной двутвар" (и аналогичные ему "Сварной короб" и т.п.) из среды КМД_РУС - не позволяют фильтровать детали по марке стали (материалу)? Детали, созданные компонентом, скрываются при любом значении фильтра "Детали - материал". Расчленение компонента не помогает.
Предпологаю, что причина может быть в создании компонента в старой версии Tekla (работаю в 17-ой), и при этом используется такой странный пользовательский атрибут, как "proMaterial", при этом в пользовательских атрибутах детали его нет, а в дереве компонента есть:
Вложение snap_001.png больше недоступно
об этом было ранее. pdimav вроде предложил решение
viewtopic.php?f=16&t=18&p=4379#p4368/
проверил только так и работает
Вложения
шаблон.jpg

Владимир Шнейдер
Сообщения: 283
Регистрация: 03 фев 2012, 17:29
Откуда: Днепропетровск

Re: Некорректная работа компонента "Сварной двутавр"

Сообщение Владимир Шнейдер » 15 дек 2013, 21:25

Danila_ZLT писал(а):За материал и профиль отвечает вкладочка "Profile properties".
IMHO Как-то странно вы себе структуру Теклы себе представляете. Ищете профиль и материал в "Определенных пользователем атрибутах".
да я то нормально представляю, просто такой польз.атрибут только тут и увидел.
Стандартные способы не работают в данном компоненте.

vladimir_a , спасибо, нашел после своего поста, действительно, так работает, хоть и недокументирован такой способ.

Ответить
phpbb3 styles

Вернуться в «Создание в Tekla Structures пользовательских компонентов»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей